Uploaded image for project: 'Atlas Module'
  1. Atlas Module
  2. ATLAS-124

Atlas server loading is broken due to missing JS library

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: TBD
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Cleaning previous tasks
    • Component/s: None
    • Labels:
      None
    • Complexity:
      Undetermined

      Description

      OpenMRS Atlas sever doesn't load (cf. the screenshot).

      In the Chrome console we can see a 404 error getting the Marker Clusterer Library, and as consequence, an UndefinedError on MarkerClusterer.

      MarkerClusterer library as moved from Google Code to Github .

      To avoid this issue in the further (in case Github stop its service , we probably would host this file on the Atlas Server

      +The incriminated include : +

      index.blade.php
      <script type="text/javascript" src="https://google-maps-utility-library-v3.googlecode.com/svn/trunk/markerclustererplus/src/markerclusterer_packed.js"></script>
       

        Gliffy Diagrams

          Attachments

          1. Capture du 2016-05-29 08-40-24.png
            45 kB
            Alexis Duque
          2. Capture du 2016-05-29 08-40-54.png
            822 kB
            Alexis Duque

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              alexis.duque Alexis Duque
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: