Uploaded image for project: 'DHIS2 Connector'
  1. DHIS2 Connector
  2. DCM-26

Update wrong module requirement versions

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None

      Description

      The list of module requirement versions is wrong and it prevents installing the module. 

      Steps to reproduce:

      Method 1:

      1. Build the module
      2. Install the omod file from the module installation window

      Method 2:

      1. Navigate to the module installation view
      2. Search for 'DhisConnector' and click install

      To resolve:

      Update the module requirements with the correct versions. (main pom file)

      The correct versions are as follows:

       

      • Reporting: 1.20.0
      • Calculation: 1.2
      • Reporting Rest: 1.11.0
      • Webservices Rest: 2.29.0
      • Serialization Xstream: 0.2.14

        Gliffy Diagrams

          Attachments

            Activity

              People

              Assignee:
              bawanthathilan Bawantha Rathnayaka
              Reporter:
              jayasanka Jayasanka Weerasinghe
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 10 minutes
                  10m
                  Remaining:
                  Remaining Estimate - 10 minutes
                  10m
                  Logged:
                  Time Spent - Not Specified
                  Not Specified