Uploaded image for project: 'Data Integrity Module'
  1. Data Integrity Module
  2. DINT-86

Missing require_version tag in config.xml causes failure on OpenMRS 1.9.x

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Should
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.4.3
    • Labels:
      None
    • Complexity:
      Low

      Description

      When trying to run the latest version of the data integrity module on an OpenMRS 1.9.x environment, the module fails to start up with error:

      WARN - ModuleFactory.startModuleInternal(637) |2020-03-31 14:07:47,277| Error while trying to start module: dataintegrityWARN - ModuleFactory.startModuleInternal(637) |2020-03-31 14:07:47,277| Error while trying to start module: dataintegrityorg.openmrs.module.ModuleException: Module requires version matching .  Current code version is 1.9.11 at org.openmrs.module.ModuleUtil.checkRequiredVersion(ModuleUtil.java:336) at org.openmrs.module.ModuleFactory.startModuleInternal(ModuleFactory.java:517) at org.openmrs.api.context.Daemon$1.run(Daemon.java:57)

      The typical solution is to add an element like this to config.xml

      <require_version>${openMRSVersion}</require_version>
      

       

        Gliffy Diagrams

          Attachments

            Activity

              People

              Assignee:
              mseaton Mike Seaton
              Reporter:
              mseaton Mike Seaton
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: