Uploaded image for project: 'Patient Flags Module'
  1. Patient Flags Module
  2. FLAG-59

Enable patient flags to run in 2.2.0 platform

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Should
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0.2
    • Labels:
      None

      Description

      When patient flags is loaded in 2.2.0 platform, it causes a n exception
      ~java.lang.NoSuchMethodError: org.openmrs.module.Module.setExtensionNames(Ljava/util/IdentityHashMap;)V
      at org.openmrs.module.patientflags.PatientFlagsModuleActivator.started(PatientFlagsModuleActivator.java:88)~
      An indicator that that method was removed in 2.2.0 platform. This needs to be fixed for distributions upgrading to 2.2.0 platform and using patient flags.

        Gliffy Diagrams

          Attachments

            Activity

              People

              Assignee:
              slubwama Samuel Lubwama
              Reporter:
              slubwama Samuel Lubwama
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: