Uploaded image for project: 'Reporting Module'
  1. Reporting Module
  2. REPORT-727

Report Status page does not refresh status correctly on OpenMRS 1.11

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: TBD
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Reporting 0.9.5
    • Component/s: None
    • Labels:
    • Complexity:
      Low

      Description

      Testing on OpenMRS 1.11, the report status page does not display any status for a requested report. This includes everything within the status section, including links to view or download the generated report.

      Peeking at the code, I suspect that something has changed in how our Ajax / Json response data is being interpreted, since we are doing something rather non-standard.

      To reproduce, create a new report definition, and then run this report from the main "Report Dashboard" page here: http://localhost:8080/openmrs/module/reporting/dashboard/index.form. This will redirect to a page (with url of module/reporting/reports/reportHistoryOpen.form?uuid=), and on the right of this page you will see a "Status" box that is empty, but should not be empty.

      The problematic code is likely that the loadReportStatus method in the ReportHistoryController (which uses a page called json.jsp to render the json response) is no longer being interpreted as json data by the calling code.

      [~djazayeri] fyi. Not sure if I tagged this right?

        Attachments

          Activity

            People

            Assignee:
            mseaton Mike Seaton
            Reporter:
            mseaton Mike Seaton
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: