Uploaded image for project: 'Webservices REST Module'
  1. Webservices REST Module
  2. RESTWS-275

Required version not working right

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • TBD
    • Resolution: Cannot Reproduce
    • 1.0
    • None
    • None
    • Undetermined

    Description

      When trying to load a compiled version of RESTWS, get message "Error while trying to start module. Module requires version between 1.8.4 and , Current code version is 1.8.4.28691."

      (Note rafa did not get this message, but his footer says "Version: 1.8.4-SNAPSHOT Build ${revisionNumber}" while mine says "Version: 1.8.4-SNAPSHOT Build 28691". My 1.8.4 is a little newer than his.)

      Tried changing <require_version>${openMRSVersion}</require_version> to <require_version>${openMRSVersion}.*</require_version>. Got message "Module requires version between 1.8.4.0 and 1.8.4.999, Current code version is 1.8.4.28691".

      Bug is that 1.8.4.28691 is not accepted as being >= 1.8.4.

      Rafa suggests that <require_version> should be hard-coded rather than rely on the variable.

      Gliffy Diagrams

        Attachments

          Activity

            People

              Unassigned Unassigned
              r.friedman Roger Friedman
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: