Uploaded image for project: 'OpenMRS SDK'
  1. OpenMRS SDK
  2. SDK-245

Upgrade Tomcat Version

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Should
    • Resolution: Fixed
    • Affects Version/s: 3.13.0, 3.13.1
    • Fix Version/s: 3.13.3
    • Component/s: SDK
    • Labels:
      None

      Description

      The SDK currently uses Tomcat 7.0.67. This version of Tomcat fails to work when using JARs built for compatibility with Java 9+ and older versions of Java. Having such a module in the classpath results in an SEVERE issue. This results in us being unable to move to more modern versions of some libraries.

      Note that this behaviour is fixed in Tomcat 7.0.76 and more recent, so this should be a pretty trivial issue.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                ibacher Ian Bacher
                Reporter:
                ibacher Ian Bacher
                Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:

                    Time Tracking

                    Estimated:
                    Original Estimate - 30 minutes
                    30m
                    Remaining:
                    Remaining Estimate - 30 minutes
                    30m
                    Logged:
                    Time Spent - Not Specified
                    Not Specified