Uploaded image for project: 'OpenMRS Core'
  1. OpenMRS Core
  2. TRUNK-2299

Standardize and improve terminology related to Void/Unvoid, and Retire/Unretire in the webapp

    XMLWordPrintable

Details

    • New Feature
    • Status: Closed
    • Should
    • Resolution: Fixed
    • None
    • None
    • None
    • None
    • Low

    Description

      Currently we tend to use the terminology "Void"/"Unvoid", and "Retire"/"Unretire" in the web application. This is not great.

      We should decide on a better terminology, and apply that across the whole web application. (We should try to do this in other languages besides English too, but that's probably another ticket.)

      My proposal is:

      • void -> Delete
      • unvoid -> Restore
      • retire -> Disable, Retire, or Deactivate
      • unretire -> Re-enable, Unretire, or Reactivate
      • purge -> Delete forever

      Next step is to do some research with implementers/users about which pair of options to go with for retire and unretire.

      Roger says: On the verbiage point, in the old days the reverse operation to delete (borrar) was recall (recrear?); it seems like the reverse of retire (retirar) should be reinstate (restablecer), but we could also go with deactivate/reactivate (desactivar/reactivar).

      Gliffy Diagrams

        Attachments

          Activity

            People

              ttcphilips Thisura Thejith
              darius Darius Jazayeri
              Votes:
              2 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: