Uploaded image for project: 'OpenMRS Core'
  1. OpenMRS Core
  2. TRUNK-4514

OpenMRS does not start if JVM is 1.8

    Details

    • Complexity:
      Low
    • Sprint:
      OpenMRS Platform 1.11 Sprint 1

      Description

      org.openmrs.api.APIException: OpenMRS requires Java 6, but is running under 1.8.0_20
      at org.openmrs.util.OpenmrsUtil.validateJavaVersion(OpenmrsUtil.java:1203)
      at org.openmrs.web.Listener.contextInitialized(Listener.java:121)

      And the initial setup screen is blank, see image attached.

      This code doesn't work:

      // check whether the current JVM version is at least Java 6
      if (JdkVersion.getMajorJavaVersion() < JdkVersion.JAVA_16)

      { throw new APIException("OpenMRS requires Java 6, but is running under " + JdkVersion.getJavaVersion()); }

      JdkVersion.JAVA_16 is a constant = 3
      when jre is 1.6 major version is 3
      when jre is 1.8 major version is 2

        Gliffy Diagrams

          Attachments

            Issue Links

              Attachments-Category-Modification

                Activity

                  People

                  • Assignee:
                    rpuzdrowski Radosław Puzdrowski
                    Reporter:
                    lluismf Lluis Martinez
                    Designated Committer:
                    Rafal Korytkowski
                  • Votes:
                    1 Vote for this issue
                    Watchers:
                    6 Start watching this issue

                    Dates

                    • Created:
                      Updated:
                      Resolved:

                      Time Tracking

                      Estimated:
                      Original Estimate - Not Specified
                      Not Specified
                      Remaining:
                      Remaining Estimate - 0 minutes
                      0m
                      Logged:
                      Time Spent - 1 day, 2 hours, 30 minutes
                      1d 2h 30m