Affects Version/s: None
Fix Version/s: Core 2.1.0
To reduce the complexity, increase readability and maintainability in
I suggest to extract related parts into smaller private methods, with longer meaningful names.
or in two methods like unsetVoidedProperties(Obs) and unsetCreationProperties(Obs)
+ remove comments.
And only extract the private methods without refactoring them as well in order to ease code review and reduce risk of breaking the code. If you have an idea on how to improve the private methods later on submit another PR.