To reduce the complexity, increase readability and maintainability in
I suggest to extract related parts into smaller private methods, with longer meaningful names:
inline temp variable
and Im sure this one
can also be extracted into a meaningfully named method.
Keep the private methods in order of their execution and right after the method saveConcept.
And only extract the private methods without refactoring them as well in order to ease code review and reduce risk of breaking the code. If you have an idea on how to improve the private methods later on submit another PR.