Uploaded image for project: 'OpenMRS Core'
  1. OpenMRS Core
  2. TRUNK-5304

Upgrade from 1.10.6 to 1.11.8 fails because of inconsistent changeset

    XMLWordPrintable

    Details

    • Complexity:
      Low

      Description

      I was just trying to upgrade from 1.10.6 to 1.11.8 and it's failing because of a checksum validation error during the liquibase update. I checked and it does look like as part of TRUNK-3422 inconsistent change sets were introduced:

      https://github.com/openmrs/openmrs-core/blob/1.10.x/api/src/main/resources/liquibase-update-to-latest.xml#L7768

      vs

      https://github.com/openmrs/openmrs-core/blob/1.11.x/api/src/main/resources/liquibase-update-to-latest.xml#L8781

      See Talk thread here:

      https://talk.openmrs.org/t/cant-upgrade-from-openmrs-1-10-6-to-openmrs-1-11-8/14747/7

      Also existing trunk ticket that introduced the issue:

      TRUNK-3422

       

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                lana Lana Honcharuk
                Reporter:
                mogoodrich Mark Goodrich
                Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:

                    Time Tracking

                    Estimated:
                    Original Estimate - Not Specified
                    Not Specified
                    Remaining:
                    Remaining Estimate - Not Specified
                    Not Specified
                    Logged:
                    Time Spent - 3 hours
                    3h