Affects Version/s: None
Fix Version/s: Core 2.3.0
This Sonar issue is about not following naming convention for method:
After checking it, I think a better thing to do is to do a little bit more than fix the name.
Right now the returned object is a map but it is actually never used as a map. The way it is used, is only to check if it contains a key: "M", or "F" - it never uses the values stored in the map.
It is also modifiable right now, which is confusing and allows for making mistakes in the code.
So I'm offering an improvement:
- fix the sonar issue,
- keep the current behavior
- make the system simpler and less error-prone