Uploaded image for project: 'OpenMRS Core'
  1. OpenMRS Core
  2. TRUNK-5480

Make ModuleUtil support more version specification format

    Details

    • Type: Enhancement
    • Status: Code Review (Post-Commit)
    • Priority: Could
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: Core 2.3.0
    • Component/s: None
    • Labels:
      None
    • Complexity:
      Low

      Description

      In ModuleUtil we can improve matchRequiredVersions method by making it support Version ranges like 1.10.4+ which mean anything higher or equal with 1.10.4 but strictly lower than 1.11.0.

       

      In other words this would cover all patch versions above a given one within a minor version.

        Gliffy Diagrams

          Attachments

            Attachments-Category-Modification

              Activity

                People

                • Assignee:
                  andu033 Andrei Stanila
                  Reporter:
                  andu033 Andrei Stanila
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:

                    Time Tracking

                    Estimated:
                    Original Estimate - 1 hour Original Estimate - 1 hour
                    1h
                    Remaining:
                    Remaining Estimate - 0 minutes
                    0m
                    Logged:
                    Time Spent - 5 hours
                    5h