Uploaded image for project: 'OpenMRS Core'
  1. OpenMRS Core
  2. TRUNK-5496

Upgrade Core to Compile and run on OpenJDK 8 ,9,10, 11,12,13,14

    XMLWordPrintable

    Details

    • Complexity:
      High
    • Sprint:
      Upgrade Libraries Sprint 1

      Description

       

      handling any other issue that may arise out of that, and updating the installation page on the wiki

      • The first work on this  ticket is to create sub-Tickets to be able to achieve this migration from 8 to 11. 

      A comment from Cintia Del Rio

      From the infrastructure point of view, moving to OpenJDK 11 really helps me a lot to support CI capabilities.
      
      The older the JDK, the more likely it’s not supported by the distribution we have.I’m having a lot of trouble supporting JDK 7 already.
      

      Ideally, we would love to support both Java 8 and 11 in order to provide a smooth transition for implementers.

      According to https://github.com/spring-projects/spring-framework/wiki/Spring-Framework-Versions, Java 11 requires spring 5.1.x

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                achilep Pahonsi Bebeto Achile
                Reporter:
                mozzy Moses Mutesasira
                Designated Committer:
                Moses Mutesasira
                Votes:
                1 Vote for this issue
                Watchers:
                10 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:

                    Time Tracking

                    Estimated:
                    Original Estimate - 2 hours Original Estimate - 2 hours
                    2h
                    Remaining:
                    Remaining Estimate - 0 minutes
                    0m
                    Logged:
                    Time Spent - 3 days
                    3d